Child pages
  • Hyak fortran
Skip to end of metadata
Go to start of metadata

To use the GNU gfortran compiler:

Below command tells you the version of gfortran:

gfortran -v


To use the Intel ifort compiler:

module load icc_17

Below command tells you the version of ifort:

ifort -v


Large Arrays:

If your Fortran program uses large arrays, then you may need to give below option to the compiler:

-mcmodel=medium   (try this first)

or

-mcmodel=large


LAPACK and BLAS:

If your Fortran program uses LAPACK or BLAS, then please see below link:

Hyak_lapack


  • No labels