Child pages
  • Wish List
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Current »

Compute Node Software Requests

PAPI, and other profiling and instrumentation tools will eventually be provided in /sw. Additional versions of standard packages such as gcc might eventually be provided in /sw.

  • A parallel (mpi capable) debugger e.g. totalview

Completed / Resolved / Fixed / Added

  • Gnuplot 4.6
  • Git
  • Graphviz
  • NetCDF

User app that can be built following the examples provided

  • autoconf (2.59) and automake (1.9) are very old ; many newer ./configure based programs require 2.60 (1.10) or greater
  • Parallel HDF5 (v. 1.6.10 or 1.8.4 compiled with the 1.6 compatibility flags from HDF5)
  • VisIt parallel-visualization tool: https://wci.llnl.gov/codes/visit/
  • HDF4
  • scons, e.g. 2.0.1 from http://www.scons.org/download.php

Suggest users use the supplied Intel libraries instead

  • scalapack, blacs
  • enthought Python distribution takes care of {numpy, scipy, matplotlib}

Installed

  • GNU Screen (http://www.gnu.org/software/screen/)
  • X11 development headers and libriaries (Xaw,Xt,...)
  • lsof (/usr/sbin/lsof)
  • valgrind <- super helpful
  • bc
  • An updated version of svn. Old svn was version 1.4.2 (r22196). The current svn is 1.6.11.
  • gcc 4.4.x (gcc44, gfortran44, g++44)
  • bzip2
  • qsub
  • vim
  • zlib
    *perl
  • man
    *flex & bison
  • More libraries (such as blas, lapack, fortran) in /usr/lib
  • gnuplot
  • python-devel
  • strace
  • split (part of coreutils)
  • No labels